Monday, October 10, 2011

spring mvc 3.x with jboss 4.x

Yikes, I hope no one has to deal with the kind of crazy that is attempting to deploy a brand new app on an ancient server.

If you're running into problems with EL being ignored in your JSTL tags, make the following fixes to web.xml:

1. Change the root tag to reflect a web-app version 2.4
<web-app version="2.4"

2. If problems still persist after re-deploy, also add this block to the file:

Source: isELIgnored="false" (JSP forum at JavaRanch)

No comments: